标签‘不建议’

多说插件在PHP5.3环境下出错实为函数规范所致

春节终于过去了,回来直接上班一周,总算可以缓口气过个周末了。顺便写下农历新年第一篇。

回归正题,虽然是元宵节+情人节,晚上依照惯例登上服务器看看博客,才想起年前博客因为迁移VPS出问题,暂时放回了早些时候用的虚拟主机,上去一看,发现5G的网站空间居然占满了,回想之前遇到过哦 1G多错误日志的情况,仔细一看,还真是php的error.log。足足4G+的大小,果断删了,过了一会在刷新,出现新的错误文件,打开发现有plugins/duoshuo/WordPress.php on line 439错误十几行,以为是多说的问题,搜了下才知道,原来是新版php不建议使用split的缘故。可能虚拟机的服务商把php升级了,所以出现这样的问题。而之前是自己配的VPS,用的还是5.2,。

下面是找到的资料,顺手也罗列出来,供大家参考。

PHP5.3 split() 不建议使用的原因:

PHP 5.3.0 之后的regex, 希望使用PCRE 的规格, POSIX Regex 查看更多...

无觅相关文章插件,快速提升流量